Nelze vybrat více než 25 témat Téma musí začínat písmenem nebo číslem, může obsahovat pomlčky („-“) a může být dlouhé až 35 znaků.
 
 
 
Sasha Aliashkevich 71d96dc1a5 v1.1.0 před 2 měsíci
.github/workflows migrating builds to electron-builder před 2 měsíci
css Show more info in case of error před 8 měsíci
examples example change před 4 roky
fonts pgtabs is going public před 5 roky
scripts fix windows build před 7 měsíci
src migrating builds to electron-builder před 2 měsíci
.eslintrc.yml fix eslint; fix build/App not found před 1 rokem
.gitignore migrating builds to electron-builder před 2 měsíci
.npmrc migrating builds to electron-builder před 2 měsíci
Info.plist Postgres protocol před 3 roky
LICENSE prepare for open source před 4 roky
README.md readme update před 2 měsíci
index.html eslint checks added; refactored to comply with eslint před 1 rokem
libpq_build.sh libpq_build; linux catchup před 5 roky
linux_build.sh 0.16.0 před 3 roky
logo.icns logo icon před 5 roky
logo.ico adding ico file for windows před 3 roky
logo.png logo icon před 5 roky
logo_sql.icns SQL Document Support for OSX před 3 roky
mac_build.sh fix mac build scripts před 7 měsíci
main.js migrating builds to electron-builder před 2 měsíci
minify.sh upgrade ulify; change mac build script; tabsplit před 1 rokem
package-lock.json migrating builds to electron-builder před 2 měsíci
package.json v1.1.0 před 2 měsíci
sqltabs.png rename to sqltabs před 5 roky
win_build.sh fix windows build před 7 měsíci

README.md

SQL Tabs

Rich SQL client. Home www.sqltabs.com

Supported databases:

- Postgresql
- MySQL / MariaDB
- MS SQL
- Amazon Redshift
- AlaSQL

Supported Platforms:

- Mac
- Windows
- Linux

Building

In order to run SQL Tabs from source code follow the next steps: (In case of any issues please report them here)

node.js not higher than v10 is required

  1. Install npm - a javascript package manager

  2. Get the code, install dependencies and build the application:

     git clone https://github.com/sasha-alias/sqltabs
     cd sqltabs
     npm install
    
  3. Run the application:

     npm start
    

Contribution and issues reports are very appreciated.

Platform specific things

You might want to rebuild grpc for firebase driver to work:

    npm rebuild grpc --runtime=electron --target=4.1.0 --target_archx64