You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
Andrew Klychkov 92f5954e19
Add CONTRIBUTING.md, REVIEW_CHECKLIST.md, MAINTAINERS (#31)
1 year ago
.github/workflows Testing against 2.11 (#22) 1 year ago
changelogs Updated query_rules parameters: cache_empty_result, OK_msg, multiplex (#25) 1 year ago
meta Require ansible-base 2.9.10+ (#2) 2 years ago
plugins Updated query_rules parameters: cache_empty_result, OK_msg, multiplex (#25) 1 year ago
roles/proxysql initial commit (#1) 2 years ago
tests Remove ingore-2.12.txt (#28) 1 year ago
.gitignore bumping to v1.0.0 (#13) 2 years ago
CHANGELOG.rst added changelog (#14) 2 years ago
CONTRIBUTING.md Add CONTRIBUTING.md, REVIEW_CHECKLIST.md, MAINTAINERS (#31) 1 year ago
CONTRIBUTORS Add CONTRIBUTORS file (#29) 1 year ago
LICENSE Initial commit 2 years ago
MAINTAINERS Add CONTRIBUTING.md, REVIEW_CHECKLIST.md, MAINTAINERS (#31) 1 year ago
README.md Add CONTRIBUTING.md, REVIEW_CHECKLIST.md, MAINTAINERS (#31) 1 year ago
REVIEW_CHECKLIST.md Add CONTRIBUTING.md, REVIEW_CHECKLIST.md, MAINTAINERS (#31) 1 year ago
codecov.yml Add codecov.yml to fix file mapping (#4) 2 years ago
galaxy.yml bumping to v1.0.0 (#13) 2 years ago

README.md

ProxySQL collection for Ansible

Plugins CI Roles CI Codecov

Code of Conduct

We follow Ansible Code of Conduct in all our interactions within this project.

Contributing to this collection

The content of this collection are made by good people like you.

All types of contributions are very welcome.

You don't know how to start? Refer to our contribution guide!

The current maintainers are listed in the MAINTAINERS file. Don't hesitate to reach them out mentioning in the proposals.

Included content

Tested with Ansible

  • 2.9
  • 2.10
  • 2.11
  • devel

External requirements

The ProxySQL modules rely on a MySQL connector. The list of supported drivers is below:

  • PyMySQL
  • MySQLdb
  • Support for other Python MySQL connectors may be added in a future release.

Using this collection

Installing the Collection from Ansible Galaxy

Before using the ProxySQL collection, you need to install it with the Ansible Galaxy CLI:

ansible-galaxy collection install community.proxysql

You can also include it in a requirements.yml file and install it via ansible-galaxy collection install -r requirements.yml, using the format:

---
collections:
  - name: community.proxysql

See Ansible Using collections for more details.

Licensing

GNU General Public License v3.0 or later.

See LICENSE to see the full text.