reduce sanity errors #19

Closed
opened 1 year ago by m · 3 comments
m commented 1 year ago (Migrated from git.osuv.de)
Owner

To become more compliant to ansible collection standard, errors from ansible-test sanity --docker default must be removed.
Unfortunately there are 999 errors atm :)

The plan is to reduce them peux a peux.

To become more compliant to ansible collection standard, errors from `ansible-test sanity --docker default` must be removed. Unfortunately there are 999 errors atm :) The plan is to reduce them peux a peux.
m commented 1 year ago (Migrated from git.osuv.de)
Owner
  • unused wildcard imports
  • future-import-boilerplate issue(s)
  • import issues
  • pep8 issues
  • docs
- [x] unused wildcard imports - [x] future-import-boilerplate issue(s) - [ ] import issues - [ ] pep8 issues - [ ] docs
m commented 1 year ago (Migrated from git.osuv.de)
Owner

116 left

116 left
m commented 1 year ago (Migrated from git.osuv.de)
Owner

only this is left, which I don't understand

ERROR: Found 9 import issue(s) on python 3.9 which need to be resolved:
ERROR: plugins/lookup/generate_password.py:12:0: traceback: AnsibleError: Please install requests library.
ERROR: plugins/lookup/passwords.py:12:0: traceback: AnsibleError: Please install requests library.
ERROR: plugins/module_utils/nextcloud.py:6:0: traceback: ImportError: import of "ansible.errors" is not allowed in this context
ERROR: plugins/modules/file.py:83:0: traceback: ImportError: import of "ansible.errors" is not allowed in this context
ERROR: plugins/modules/file_info.py:37:0: traceback: ImportError: import of "ansible.errors" is not allowed in this context (at plugins/module_utils/nextcloud.py:6:0)
ERROR: plugins/modules/password.py:80:0: traceback: ImportError: import of "ansible.errors" is not allowed in this context (at plugins/module_utils/nextcloud.py:6:0)
ERROR: plugins/modules/password_info.py:33:0: traceback: ImportError: import of "ansible.errors" is not allowed in this context (at plugins/module_utils/nextcloud.py:6:0)
ERROR: plugins/modules/talk.py:42:0: traceback: ImportError: import of "ansible.errors" is not allowed in this context (at plugins/module_utils/nextcloud.py:6:0)
ERROR: plugins/modules/user_info.py:28:0: traceback: ImportError: import of "ansible.errors" is not allowed in this context (at plugins/module_utils/nextcloud.py:6:0)

only this is left, which I don't understand ``` ERROR: Found 9 import issue(s) on python 3.9 which need to be resolved: ERROR: plugins/lookup/generate_password.py:12:0: traceback: AnsibleError: Please install requests library. ERROR: plugins/lookup/passwords.py:12:0: traceback: AnsibleError: Please install requests library. ERROR: plugins/module_utils/nextcloud.py:6:0: traceback: ImportError: import of "ansible.errors" is not allowed in this context ERROR: plugins/modules/file.py:83:0: traceback: ImportError: import of "ansible.errors" is not allowed in this context ERROR: plugins/modules/file_info.py:37:0: traceback: ImportError: import of "ansible.errors" is not allowed in this context (at plugins/module_utils/nextcloud.py:6:0) ERROR: plugins/modules/password.py:80:0: traceback: ImportError: import of "ansible.errors" is not allowed in this context (at plugins/module_utils/nextcloud.py:6:0) ERROR: plugins/modules/password_info.py:33:0: traceback: ImportError: import of "ansible.errors" is not allowed in this context (at plugins/module_utils/nextcloud.py:6:0) ERROR: plugins/modules/talk.py:42:0: traceback: ImportError: import of "ansible.errors" is not allowed in this context (at plugins/module_utils/nextcloud.py:6:0) ERROR: plugins/modules/user_info.py:28:0: traceback: ImportError: import of "ansible.errors" is not allowed in this context (at plugins/module_utils/nextcloud.py:6:0) ```
Sign in to join this conversation.
No Milestone
No project
No Assignees
1 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.